Урок 4 Виды циклов в системе программирования КуМир



Скачать 32.71 Kb.
НазваниеУрок 4 Виды циклов в системе программирования КуМир
Дата08.03.2013
Размер32.71 Kb.
ТипУрок
источник

Урок 4

Виды циклов в системе программирования КуМир

      Алгоритмы, отдельные действия которых многократно повторяются, называются алгоритмами циклической структуры. Совокупность действий алгоритма, связанную с повторением, называют циклом.
          Команда цикла обеспечивает повторное выполнение последовательности команд (тела цикла) по некоторому условию.
         Для программирования алгоритмов циклической структуры в системе программирования КуМир предусмотрено два вида циклов: цикл с предусловием (цикл пока) и цикл с параметром (цикл для).

  ^ Цикл с предусловием (цикл пока)

       Цикл с предусловием (цикл пока) - цикл, выполнение которого повторяется, пока истинно условие цикла. Служебные слова ^ НЦ (начало цикла) и КЦ (конец цикла)пишутся строго одно под другим и соединяются вертикальной чертой. Правее этой черты записывается повторяемая последовательность команд (тело цикла).





         При его выполнении ЭВМ циклически повторяет следующие действия:
                 а) проверяет записанное после слова пока условие;
                б) если условие не соблюдается (условие ложно), то выполнение цикла завершается и ЭВМ начинает выполнять команды, записанные после КЦ. Если же условие соблюдается (условие истинно), то ЭВМ выполняет тело цикла, снова проверяет условие и т.д.
         Если условие в цикле пока не соблюдается с самого начала, то тело цикла не выполняется ни разу.
         Замечание. Выполнение цикла пока может и не завершиться, если условие все время будет истинным (эту ситуацию принято называть зацикливанием). Поэтому во избежание подобных ситуаций в теле цикла должны содержаться команды изменения условия.

Найти значение у=Х2, если х=2,4,6,…10

  алг квадрат
  нач цел х,у, i
         i : = 2
         нц пока i < = 10
у:=х**2
               i : = i + 2

вывод ' у = ', у      
         кц 
  кон
    

Цикл с параметром (цикл для)

       

^ Цикл с параметром (цикл для) - повторное выполнение тела цикла, пока целочисленный параметр пробегает множество всех значений от начального ( i1 ) до конечного ( in ):






……………………………….

         Здесь i - переменная целого типа, называемая параметром цикла: i1, in - начальное и конечное значения параметра цикла, которые могут быть заданы либо произвольными целыми числами, либо выражениями с целыми значениями; h - шаг изменения значения параметра цикла, значением шага может быть любое целое число (как положительное, так и отрицательное). Запись "шаг h" в первой строке может вообще отсутствовать, при этом по умолчанию значение шага принимается равным 1.
         При выполнении цикла для, его тело выполняется для i = i1, i = i1 + h, i = i1 + 2*h, . . . , i = in. Правила алгоритмического языка допускают задание любых целых i1, in, h. В частности, in может быть меньше i1. Если при этом значение h < 0, то цикл выполняется нужное количество раз, а если h имеет положительное значение, то этот случай не считается ошибочным - просто тело цикла не будет выполнено ни разу, а ЭВМ сразу перейдет к выполнению команд, записанных после КЦ. При h = 0 происходит зацикливание.

Пример:   предыдущая задача вторым способом    Найти значение у=Х2, если х=2,4,6,…10


  алг функция
  нач

цел х,у,
        
        
         нц для х от 2 до 10 шаг 2
               у:=х**2

вывод ' у= ', у     
         кц
          кон
    

Задачи для самостоятельного решения



  1. Составить программу определения функции У=2x, где х=1,2,3…12

    . . алг формула
    . . нач
    . . . цел n,х,y
    . . . вывод "введите степень "
    . . . ввод n
    . . . нц для х от 1 до n шаг 1
    . . . . y:=2**х
    . . . . вывод нс ,"y= ",y
    . . . .
    . . . кц
    . . кон



    n=6
    х=6
    y=64


  2. Вывести на печать таблицу умноженя числа А на В, где В=1,2,3….n

    . . алг умножение
    . . нач
    . . . цел а,в,с
    . . . вывод нс,"введи а="
    . . . ввод а
    . . . вывод нс,"введи конечное в="
    . . . ввод в
    . . . нц для с от 1 до в
    . . . .
    . . . . вывод нс,а,"х",с,"=",а*с
    . . . кц
    . . .
    . . .
    . . кон






  3. Написать программу ввода целых чисел с клавиатуры пока не будет введен 0

. . алг числа
. . нач
. . . цел а,в,с
. . . а:=2
. . .
. . . нц пока а<>0
. . . . вывод нс,"введи а="
. . . . ввод а
. . . . вывод нс," а=",а
. . . кц
. . . вывод нс,"вы ввели 0"
. . .
. . кон



а=2

нет

а=0



Добавить документ в свой блог или на сайт


Похожие:



Если Вам понравился наш сайт, Вы можеть разместить кнопку на своём сайте или блоге:
refdt.ru


©refdt.ru 2000-2013
условием копирования является указание активной ссылки
обратиться к администрации
refdt.ru